Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

PlantSight Website not loading in US & Brazil

Incident Report for Bentley Systems, Inc

Resolved

This incident has been resolved and PlantSight (plantsight.bentley.com) is now working normally.

Thank you for your cooperation.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 30, 2025 - 15:26 UTC

Investigating

Our team is currently investigating an issue with PlantSight (plantsight.bentley.com). Some users may be experiencing difficulties accessing the site.
We are working diligently to identify the root cause and implement a solution. Updates will be provided as more information becomes available.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Apr 30, 2025 - 14:52 UTC
This incident affected: iTwin Products (PlantSight).