Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Microsoft Azure- Unexpected latencies - South Africa North and South Africa West cloud services affected.
Incident Report for Bentley Systems, Inc
Resolved
This incident has been resolved and Microsoft Azure is now working normally.
Thank you for your cooperation.
Posted Mar 18, 2024 - 13:51 UTC
Monitoring
Our team has been working quickly to restore full functionality to Microsoft Azure - Unexpected latencies and we have implemented a fix. We are now monitoring the system for stability and customer experience.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Mar 18, 2024 - 05:57 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 15, 2024 - 16:10 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 15, 2024 - 09:48 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 15, 2024 - 07:26 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 15, 2024 - 07:09 UTC
Identified
The overall network health for the Africa region has been steadily improving from yesterday. Many of the cloud services that were affected earlier by this issue have returned to their normal levels. We are still validating for any remaining services.
Posted Mar 15, 2024 - 07:06 UTC
Update
We are continuing to investigate this issue.
Posted Mar 15, 2024 - 04:14 UTC
Update
We are continuing to investigate this issue.
Posted Mar 14, 2024 - 13:22 UTC
Update
We are continuing to investigate this issue.
Posted Mar 14, 2024 - 12:12 UTC
Update
We are continuing to investigate this issue.
Posted Mar 14, 2024 - 12:07 UTC
Update
Bentley Systems is currently investigating a latency issue within in Africa region. This issue may be affecting all users accessing cloud services from Africa region.
We are working diligently to identify the root cause of the problem and implement a solution. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Mar 14, 2024 - 12:04 UTC
Investigating
The Microsoft Azure team is currently investigating an issue with Virtual Machines being down. Some users may be having trouble or may experience connection failures when trying to access some Virtual Machines using certain features.
The Bentley Team is monitoring the situation, in the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Mar 14, 2024 - 11:55 UTC
This incident affected: SYNCHRO (SYNCHRO 4D, SYNCHRO Control, SYNCHRO Cost), ALIM (Session Service), ProjectWise Services (Design Review, Forms, Issue Resolution, ProjectWise Design Integration), iTwin Platform (Changed Elements, Clash Detection, Export, Forms, iModels, Issues, Mesh Export, Property Validation, Reporting, Saved Views, Storage, Synchronization, Transformations, Visualization), and iTwin Services (Platform APIs).