Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Bentley A365- Call Center User entitlements down
Incident Report for Bentley Systems, Inc
Resolved
Issue has been resolved and is now back in operation.
Posted Nov 09, 2023 - 00:36 UTC
Identified
Our team identified that the UCC entitlements are down and needed to reboot North America A365 due to entitlements that are not operating.
Some users may be having trouble using the A365 call center for entitlements or using certain features.
We are working diligently to identify the root cause of the problem and implement a solution. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Nov 09, 2023 - 00:16 UTC
This incident affected: Base Services (Phone System).