Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

iTwin Developer Portal - Application creation/management functionality is degraded
Incident Report for Bentley Systems, Inc
Resolved
This incident has been resolved and iTwin Developer Portal - Application creation/management functionality is now working normally.
Thank you for your cooperation.
Posted Feb 08, 2024 - 16:53 UTC
Investigating
Our team is currently investigating an issue with iTwin Developer Portal. Some users may be having trouble application creation and updates within the developer.bentley.com or using certain features.
We are working diligently to identify the root cause of the problem and implement a solution. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Feb 08, 2024 - 11:39 UTC
This incident affected: iTwin Services (Platform Developer Portal).