Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Network connectivity issues in South Africa

Incident Report for Bentley Systems, Inc

Resolved

This issue has been resolved. It was due to a network disruption involving a third-party telecom provider in the affected regions.
Posted May 14, 2025 - 11:26 UTC

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 10:11 UTC

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 08:55 UTC

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 07:49 UTC

Investigating

Our team is currently investigating an issue. Users may experience performances issues to sign in or load websites from South Africa region.

We are working diligently to identify the root cause and implement a solution. We will provide updates as we learn more.

In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted May 14, 2025 - 06:46 UTC
This incident affected: Identity Management Systems (IMS) (Authentication / Login).