Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

IMS - Multiple users are facing login issues in connection client
Incident Report for Bentley Systems, Inc
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 03:12 UTC
Update
This incident has been resolved and IMS is now working normally.
Thank you for your cooperation.
Posted Oct 11, 2024 - 03:01 UTC
Update
We are continuing to investigate this issue.
Posted Oct 11, 2024 - 02:33 UTC
Investigating
Our team is currently investigating an issue with IMS. Some users may have trouble logging in to the connection client or using certain features.
We are working diligently to identify the root cause of the problem and implement a solution. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Oct 11, 2024 - 02:18 UTC
This incident affected: Identity Management Systems (IMS) (Authentication / Login).