Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

ProjectWise Explorer Sign In Issue

Incident Report for Bentley Systems, Inc

Resolved

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. Please kindly continue to check he CrowdStrike support page for further information. https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter
Posted Apr 16, 2025 - 15:04 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using
CrowdStrike software. CrowdStrike has published an update on their support page which may related
https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 13:47 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 12:38 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 11:20 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 10:19 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 09:22 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 07:58 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 06:22 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 05:29 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 04:08 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 16, 2025 - 02:49 UTC

Update

We are continuing to investigate this issue.
Posted Apr 16, 2025 - 02:14 UTC

Update

We are continuing to investigate this issue.
Posted Apr 16, 2025 - 01:07 UTC

Update

We are continuing to investigate this issue.
Posted Apr 16, 2025 - 00:10 UTC

Update

We are continuing to investigate this issue.
Posted Apr 15, 2025 - 23:09 UTC

Update

We are continuing to investigate this issue.
Posted Apr 15, 2025 - 22:07 UTC

Update

The issue appears to only be impacting users with a combination of KB5055523 on Windows 11 while using CrowdStrike software. CrowdStrike has published an update on their support page which may be related https://supportportal.crowdstrike.com/s/article/Some-applications-may-crash-after-installing-Windows-KB5055523-when-AUMD-is-enabled%EF%BF%BCAfter.

We are continuing to investigate this issue with Microsoft and CrowdStrike. This article will be updated as more information becomes available.
Posted Apr 15, 2025 - 21:03 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 19:58 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 19:01 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 18:05 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 16:58 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 15:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 15:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 12:53 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 11:33 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 10:29 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 09:23 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 08:15 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 07:04 UTC

Update

We are continuing to work on a fix this issue.
Posted Apr 15, 2025 - 06:08 UTC

Update

We are continuing to work on a fix this issue.
Posted Apr 15, 2025 - 05:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 04:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 03:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 01:53 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 00:53 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 14, 2025 - 23:53 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 14, 2025 - 22:56 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 14, 2025 - 21:55 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 14, 2025 - 20:48 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 14, 2025 - 19:42 UTC

Update

We are continuing to work on a fix this issue.
Posted Apr 14, 2025 - 18:29 UTC

Identified

We have identified the issue and are working with Microsoft to resolve it. We will provide updates as we learn more and once a fix is implemented. Thank you for your patience.
Posted Apr 14, 2025 - 17:08 UTC

Update

We are continuing to investigate this issue.
Posted Apr 14, 2025 - 16:05 UTC

Investigating

Please be aware that a recent Windows 11 Cumulative Update (KB5055523) is impacting ProjectWise Explorer versions 2023 and later which may result in users being unable to sign-in to ProjectWise Explorer.

We are reviewing this issue, but note that this Windows Update is also impacting other applications. Currently the only available resolution is to not install and/or remove the update until Microsoft provides a mitigation for this issue. For impacted accounts, we recommend that you review this issue with your IT & Security department.
Posted Apr 11, 2025 - 22:18 UTC
This incident affected: ProjectWise Services (ProjectWise Design Integration).