Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

MicroSoft Azure Services - Southeast Asia

Incident Report for Bentley Systems, Inc

Resolved

This incident from the Microsoft has been resolved.
Posted Aug 18, 2025 - 20:00 UTC

Investigating

We are currently investigating the connectivity issue at Southeast Asia with Microsoft. Some users may be having trouble or may experience connection failures. We will provide the update as soon as new information is available.
Posted Aug 18, 2025 - 19:54 UTC