Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Service Now - Page unresponsive canvas error

Incident Report for Bentley Systems, Inc

Resolved

This incident has been resolved and Service Now - Page is now working normally.
Thank you for your cooperation.
Posted Jul 11, 2024 - 03:17 UTC

Identified

We are experiencing intermittent issues with our platform that hosts our Communities and Bentley Support Portal.
We are engaged with the platform hosting provider to resolve the error quickly.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Jul 11, 2024 - 03:08 UTC

Investigating

Our team has been working quickly to restore full functionality to *Service Now and we have implemented a fix. We are now monitoring the system for stability and customer experience.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Jul 11, 2024 - 03:05 UTC
This incident affected: Base Services (Support Portal).