Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

iTwin Services - Platform Developer Portal service is degraded due to outage on the snow flake service in East US2
Incident Report for Bentley Systems, Inc
Resolved
Microsoft Azure reports Snowflake faced wider server issues, which caused service to become unavailable. We've implemented the fix for this issue, and we'll continue to monitor the environment until we're confident all services are functioning properly.
Posted Apr 04, 2024 - 12:51 UTC
Identified
We have identified the root cause of the issue with iTwin Services - Platform Developer Portal service that may impact SOME of the reports in the reporting site. this is due to an outage on the snow flake service in East US2.

Bentley Systems is monitoring the Snowflake status and when resolved will update the Bentley Status to reflect this.
Posted Apr 04, 2024 - 12:34 UTC
This incident affected: iTwin Services (Platform Developer Portal).