Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Visualization service in the East US region

Incident Report for Bentley Systems, Inc

Resolved

This incident has been resolved and all services are now working normally.
Thank you for your patience.
Posted Aug 23, 2024 - 14:23 UTC

Update

Our team is currently investigating an issue with iTwins Platform Visualization service in the East US region. Some users may be having trouble using certain features.
This issue is with Microsoft Service. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Aug 23, 2024 - 10:40 UTC

Update

The support has found that the PlantSight service is also affected by this same problem.
Posted Aug 22, 2024 - 20:15 UTC

Update

We have update for Transformation and ProjectWise Services - >Design Review for the same issue.
Posted Aug 22, 2024 - 17:17 UTC

Update

Support has found that the Clash Detection service in EUS is affected by this same problem.
Posted Aug 22, 2024 - 16:13 UTC

Investigating

Our team is currently investigating an issue with iTwins Platform Visualization service in the East US region. Some users may be having trouble using certain features.
This issue is with Microsoft Service. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Aug 22, 2024 - 13:51 UTC
This incident affected: ProjectWise Services (Design Review), iTwin Platform (Clash Detection, Transformations, Visualization), and iTwin Products (PlantSight).