Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Bing Maps is unavailable
Incident Report for Bentley Systems, Inc
Resolved
This incident has been resolved and Bing Maps is now working normally.
Thank you for your cooperation.
Posted Oct 15, 2024 - 17:06 UTC
Identified
We have identified the root cause of the issue with Bing Maps causing errors with multiple Bentley Platforms.
Our team is working on to resolve the issue and restore full functionality to Bing Service as soon as possible. We will provide updates as we learn more and once a fix is implemented.
Posted Oct 15, 2024 - 16:04 UTC
This incident affected: ALIM (Session Service).