Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Microsoft Azure-West Europe-Virtual Machines are down
Incident Report for Bentley Systems, Inc
Resolved
Microsoft Azure restored power at approximately 08:00 UTC, and started to safely bring affected infrastructure back online. Once networking and storage infrastructure had recovered, compute scale units were brought back into service.
https://azure.status.microsoft/en-us/status
Posted Oct 20, 2023 - 14:25 UTC
Monitoring
Microsoft Team has been working quickly to restore full functionality to the Connectivity issue while accessing Virtual Machines and the team has implemented a fix. We are now monitoring the system for stability and customer experience.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Oct 20, 2023 - 13:26 UTC
This incident affected: iTwin Products (OpenCities Planner) and ProjectWise Services (ProjectWise Design Integration).