Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Issue when checking in files that have been checked out with ProjectWise Web using PW Drive integration.
Incident Report for Bentley Systems, Inc
Resolved
This incident has been resolved and ProjectWise Web using PW Drive integration is now working normally.
Thank you for your cooperation.
Posted Dec 15, 2023 - 20:48 UTC
Identified
Please note that there is currently an issue when checking in files that have been checked out with ProjectWise Web using PW Drive integration. If you experience this, we recommend using PW Drive to check in the file until this issue has been resolved. We are working diligently to resolve this issue and apologize for any inconvenience this may cause.
Posted Dec 15, 2023 - 16:38 UTC
This incident affected: ProjectWise Services (ProjectWise Web View).