Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Intermittent issue with ProjectWise Web Document Services

Incident Report for Bentley Systems, Inc

Update

We are continuing to work on a fix for this issue.
Posted May 01, 2025 - 21:11 UTC

Identified

We are aware of an intermittent issue that is impacting ProjectWise Web users ability to work with their ProjectWise documents. We have identified the issue which is limited to users on ProjectWise Server 2024.02. We are working to resolve the issue and will provide additional updates as we learn more. Thank you for your patience.
Posted May 01, 2025 - 21:09 UTC
This incident affects: ProjectWise Services (ProjectWise Web View).