Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

ALIM Email Notification Issue

Incident Report for Bentley Systems, Inc

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 19:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 18:33 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 14, 2025 - 17:10 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 14, 2025 - 16:04 UTC

Identified

The issue has been identified, and we are working to fix it. We will keep you posted as soon as a new update is available. Thank you for your patience.
Posted Apr 14, 2025 - 14:04 UTC

Investigating

Please be aware that we are currently experiencing an issue with email notifications. We are actively investigating to determine the cause. We apologize for the inconvenience and thank you for your patience.
Posted Apr 14, 2025 - 13:36 UTC
This incident affected: ALIM (Session Service).