Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Chrome and Chromium (version 130.xx) is resulting in a compatibility issue
Incident Report for Bentley Systems, Inc
Resolved
We completed our update for PW365 in production so now the issue should be resolved in all products.

Thank you for your cooperation.
Posted Oct 22, 2024 - 15:18 UTC
Update
The ProjectWise ‘Get Links’ functionality has been restored.

There is still a compatibility issue with the ‘Go to ProjectWise Explorer’ function when it is selected in ProjectWise 365 (https://projectwise365.bentley.com) for users who are running Google Chrome version 130.xx. We anticipate this issue will be resolved by 22 October, 2024.
Posted Oct 22, 2024 - 14:19 UTC
Update
The ProjectWise ‘Get Links’ functionality has been restored.

There is still a compatibility issue with the ‘Go to ProjectWise Explorer’ function when it is selected in ProjectWise 365 (https://projectwise365.bentley.com) for users who are running Google Chrome version 130.xx. We anticipate this issue will be resolved by 22 October, 2025.
Posted Oct 21, 2024 - 15:35 UTC
Update
A recent Google update to Chrome and Chromium (version 130.xx) is resulting in a compatibility issue with the ProjectWise ‘Get Link’ functionality. This issue impacts the Get Link functionality for ProjectWise Explorer, ProjectWise Web, and ProjectWise Drive.
Bentley is aware of the issue and is continuing to work to fully resolve it. Sorry for the inconvenience caused. Thank you for your patience
Posted Oct 19, 2024 - 01:11 UTC
Identified
A recent Google update to Chrome and Chromium (version 130.xx) is resulting in a compatibility issue with the ProjectWise ‘Get Link’ functionality. This issue impacts the Get Link functionality for ProjectWise Explorer, ProjectWise Web, and ProjectWise Drive.
Bentley is aware of the issue and is continuing to work to fully resolve it. Sorry for the inconvenience caused. Thank you for your patience
Posted Oct 18, 2024 - 18:36 UTC
This incident affected: ProjectWise Services (ProjectWise 365, ProjectWise Design Integration, ProjectWise Drive).