Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Outage in Subscription Analytics Portal
Incident Report for Bentley Systems, Inc
Resolved
This incident has been resolved and the Subscription Analytics Portal is now working normally.
Thank you for your cooperation.
Posted Feb 08, 2024 - 13:07 UTC
Update
Our team has been working quickly to restore full functionality to Subscription Analytics Portal and we have implemented a fix. We are now monitoring the system for stability and customer experience.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Feb 08, 2024 - 08:57 UTC
Monitoring
Our team has been working quickly to restore full functionality to Subscription Analytics Portal and we have implemented a fix. We are now monitoring the system for stability and customer experience.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Feb 07, 2024 - 21:58 UTC
Identified
We’re currently experiencing an outage from Qlik Cloud US which is affecting the Subscription Analytics Portal from loading many of the reports.
Our team is working on to resolve the issue and restore full functionality to **Subscription Analytics Portal** as soon as possible. We will provide updates as we learn more and once a fix is implemented.
Posted Feb 07, 2024 - 18:37 UTC
This incident affected: Subscription Entitlement Services (Subscription Analytics).