Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Get Links in ProjectWise Explorer Versions 10.00.03.434 and 10.00.03.453 are not functioning correctly
Incident Report for Bentley Systems, Inc
Resolved
The development team has identified the root cause for this issue and they have now restored the ‘Get Link’ functionality in ProjectWise Explorer 10.00.03.434 and 10.00.03.453. Our internal testing has confirmed that this is now working. Thank you for your patience.
Posted Dec 01, 2023 - 15:57 UTC
Update
Based on our initial investigation we believe that this issue is related a recent update to Chromium, a 3rd party component that is used to render the ‘Get Links’ dialog.

We are continuing to investigate options to restore the Get Links functionality. Please note that the Get Links function continues to work in ProjectWise Explorer 2023 as it uses an updated version of Chromium which is not impacted by these recent Chromium updates. The Get Links function is also available via the ProjectWise Web interface.
Posted Dec 01, 2023 - 14:53 UTC
Update
Based on our initial investigation we believe that this issue is related a recent update to Chromium, a 3rd party component that is used to render the ‘Get Links’ dialog.

We are continuing to investigate options to restore the Get Links functionality. Please note that the Get Links function continues to work in ProjectWise Explorer 2023 as it uses an updated version of Chromium which is not impacted by these recent Chromium updates. The Get Links function is also available via the ProjectWise Web interface.
Posted Dec 01, 2023 - 00:25 UTC
Investigating
PW Explorer 10.00.03.434 and 10.00.03.453 display a blank window when you right-click on a file and select "Get Link".
This issue is not affecting PW Explorer 23.5.00.11.
Our Dev team is aware of this and is actively working on it.
Posted Nov 30, 2023 - 22:45 UTC
This incident affected: ProjectWise Services (ProjectWise Design Integration).