Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Education Site Product Downloads - Service Disruption

Incident Report for Bentley Systems, Inc

Resolved

Service has been restored, and product downloads from the Education site are now functioning normally.

Our team identified and resolved the underlying issue, and we have confirmed that downloads are once again available to users. We will continue to monitor the environment to ensure stability.

Thank you for your patience and understanding while we worked to restore service.
Posted Sep 17, 2026 - 16:47 UTC

Investigating

We are currently experiencing an issue that is preventing product downloads from the Education site. Our team has identified the cause and is actively working on a fix. We expect service to be restored shortly and apologize for the inconvenience.
Posted Sep 17, 2026 - 16:27 UTC
This incident affected: Base Services (Education).