Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Microsoft Azure outage in the Central US region affecting Bentley hotline and customer environments
Incident Report for Bentley Systems, Inc
Resolved
12:15 UTC on 19 July 2024 – Services which were impacted by this outage recovered progressively and engineers from the respective teams intervened where further manual recovery was needed. Following an extended monitoring period, we determined that impacted services had returned to their expected availability levels.
Posted Jul 19, 2024 - 16:57 UTC
Update
We have identified the root cause of the issue, Due to a reported outage in the Central US region in azure, this is affecting our customers who's environments reside in this region along with the Bentley Hotline.

Azure are currently applying mitigation. Customers should continue to see increasing recovery at this time as residual and downstream impact mitigation progresses.

We will provide updates as we learn more and once a fix is implemented.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jul 19, 2024 - 08:55 UTC
Update
We have identified the root cause of the issue, Due to a reported outage in the Central US region in azure, this is affecting our customers who's environments reside in this region along with the Bentley Hotline.

Azure are currently applying mitigation. Customers should continue to see increasing recovery at this time as residual and downstream impact mitigation progresses.

We will provide updates as we learn more and once a fix is implemented.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jul 19, 2024 - 04:08 UTC
Update
We have identified the root cause of the issue, Due to a reported outage in the Central US region in azure, this is affecting our customers who's environments reside in this region along with the Bentley Hotline.
Azure are currently applying mitigation. Customers should see signs of recovery at this time as mitigation applies across resources in the region

We will provide updates as we learn more and once a fix is implemented.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jul 19, 2024 - 02:43 UTC
Update
We have identified the root cause of the issue, Due to a reported outage in the Central US region in azure, this is affecting our customers who's environments reside in this region along with the Bentley Hotline.

We will provide updates as we learn more and once a fix is implemented.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jul 19, 2024 - 01:50 UTC
Update
We have identified the root cause of the issue related to Microsoft Azure Central US region impacting hotline platform.
Due to a reported outage in the Central US region in azure, this is affecting our customers who's environments reside in this region along with the Bentley Hotline.

We will provide updates as we learn more and once a fix is implemented.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jul 19, 2024 - 00:47 UTC
Identified
We have identified the root cause of the issue related to Microsoft Azure Central US region impacting hotline platform.

Our team is working on to resolve the issue and restore full functionality to Phone System Hotline as soon as possible. We will provide updates as we learn more and once a fix is implemented.
Posted Jul 19, 2024 - 00:22 UTC
Update
We are continuing to investigate this issue.
Posted Jul 18, 2024 - 23:55 UTC
Investigating
Our team is currently investigating an issue with our Phone System Hotline. Some users may be having trouble calling North America hotline for support.
We are working diligently to identify the root cause of the problem and implement a solution. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jul 18, 2024 - 23:54 UTC
This incident affected: Base Services (Managed Services (Global Status), Phone System).