Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Microsoft Azure-East US 2-Virtual Machines are down.
Incident Report for Bentley Systems, Inc
Resolved
This incident has been resolved.
Posted Dec 03, 2023 - 16:00 UTC
Update
We are continuing to investigate this issue.
Posted Dec 03, 2023 - 14:19 UTC
Update
We are continuing to investigate this issue.
Posted Dec 03, 2023 - 13:19 UTC
Update
The Microsoft Azure team is currently investigating an issue with Virtual Machines being down. Some users may be having trouble or may experience connection failures when trying to access some Virtual Machines using certain features.
Microsoft Team is working diligently to identify the root cause of the problem and implement a solution. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Dec 03, 2023 - 12:48 UTC
Investigating
The Microsoft Azure team is currently investigating an issue with Virtual Machines being down. Some users may be having trouble or may experience connection failures when trying to access some Virtual Machines using certain features.
Microsoft Team is working diligently to identify the root cause of the problem and implement a solution. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Dec 03, 2023 - 12:23 UTC
This incident affected: iTwin Products (OpenCities Planner) and ProjectWise Services (ProjectWise Design Integration).