Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

Issue with Phone Systems

Incident Report for Bentley Systems, Inc

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 17:36 UTC

Monitoring

The issue affecting our phone systems has been resolved, and services are now fully operational. We are continuing to closely monitor system performance to ensure stability.

We apologize for the disruption and appreciate your patience and understanding throughout this incident.
Posted Jun 11, 2026 - 17:30 UTC

Identified

We are currently experiencing issues with our phone systems that may impact your ability to reach Bentley support by phone.

Our teams are actively working to resolve the issue. In the meantime, we encourage customers to use the following alternative support channels:

• Submit a support request via the Bentley Support portal (https://bentleysystems.service-now.com/csp)
• Contact your account representative by email

We will continue to post updates here as our investigation progresses. We apologize for the disruption and thank you for your patience.
Posted Jun 11, 2026 - 15:24 UTC
This incident affected: Base Services (Phone System).