Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

iTwin Services - Design Review

Incident Report for Bentley Systems, Inc

Resolved

This incident has been resolved.
Thank you for your patience.
Posted Aug 25, 2026 - 13:48 UTC

Monitoring

We have identified and implemented a fix for the issue. We will continue to closely monitor performance. Thank you for your patience.
Posted Aug 25, 2026 - 12:51 UTC

Investigating

We are currently investigating potential degradation of iTwin Design services in the Europe and Asia regions.

We will provide updates as soon as new information becomes available. Thank you for your patience.
Posted Aug 25, 2026 - 11:41 UTC
This incident affected: iTwin Services (Design Insights, Design Validation).