Bentley Cloud Services Status

Welcome to Bentley Systems health dashboard. Here you can follow the operational status of our products as well as other key features and services.

Any issue or interruptions we encounter will be listed on this page.

CrowdStrike Global Outage Impacting Bentley Systems Network
Incident Report for Bentley Systems, Inc
Postmortem

Bentley Systems RCA Report

Incident Start Date: 07-19-2024
Incident Start Time: 04:09 AM UTC
Incident End Date: 07-20-2024
Incident End Time: 06:00 PM UTC
Duration of Incident: 2,271 minutes (37 hours, 51 minutes)
Incident ID: INC0204562
Service Impacted: Bentley Systems Managed Services
Customers Impacted: All Global Managed Services Accounts

Impact

Services impacted were the Managed Service Global Infrastructure consisting of virtual cloud Windows servers.

All accounts using managed services were impacted.

Root Cause

The latest patch for CrowdStrike Falcon Sensor software negatively impacted Microsoft Windows Cloud servers.  This caused machines to experience BSOD failure errors (Blue Screen of Death) and continuous loop restarts.

Proactive Measures

On 07-20-2024 at 6:00 PM UTC, confirmation that full functionality was restored post CrowdStrike software release for all affected Microsoft Windows Cloud Virtual Machines.

Following an extended period of monitoring, Bentley has determined this incident has been resolved.

Next Steps

Further investigation of the event and conditions that led to the disruption, will be reviewed to mitigate external factors that might affect our services in the future.

Bentley Systems Contact Information

To obtain the local contact information please click on the link for: Bentley Offices

You can follow the status of major events on www.status.bentley.com

We apologize for any inconvenience this may have caused.  We recognize that any disruption of service is undesirable, so we will continue to research and evaluate potential changes to ensure a consistent, high-level quality of service.

Posted Jul 25, 2024 - 00:08 UTC

Resolved
All systems have been successfully recovered following the Crowdstrike Outage and are currently under active monitoring by our support teams.
Posted Jul 21, 2024 - 13:14 UTC
Update
All systems have been successfully recovered following the Crowdstrike Outage and are currently under active monitoring by our support teams.
Posted Jul 20, 2024 - 19:22 UTC
Update
Our dedicated teams are actively working to restore all Bentley systems and services to full functionality following the effects of the global update issued by third-party application, CrowdStrike. We are committed to providing you with continuous updates. We value your patience and cooperation while we work to resolve this matter.

The majority of the services have now been restored and most services should be operational. Bentley is still continuing some mitigation work, which involves restarting systems, therefore users can experience intermittent issues.
Posted Jul 20, 2024 - 16:13 UTC
Monitoring
Our dedicated teams are actively working to restore all Bentley systems and services to full functionality following the effects of the global update issued by third-party application, CrowdStrike. We are committed to providing you with continuous updates. We value your patience and cooperation while we work to resolve this matter.

The majority of the services have now been restored and most services should be operational. Bentley is still continuing some mitigation work, which involves restarting systems, therefore users can experience intermittent issues.
Posted Jul 20, 2024 - 15:48 UTC
Identified
Our dedicated teams are actively working to restore all Bentley systems and services to full functionality following the effects of the global update issued by third-party application, CrowdStrike. We are committed to providing you with continuous updates. We value your patience and cooperation while we work to resolve this matter.

Whilst our Teams continue to work vigorously to restore all Bentley Systems and Services. We have the following update for Microsoft:
Awareness - Virtual Machines
We are aware of an issue that started on 19 July 2024 at 04:09UTC, which resulted in customers experiencing unresponsiveness and startup failures on Windows machines using the CrowdStrike Falcon agent, affecting both on-premises and various cloud platforms (Azure, AWS, and Google Cloud).
It’s important to clarify that this incident is separate from the resolved Central US Azure outage (Tracking Id: 1K80-N_8). Microsoft is actively providing support to assist customers in their recovery on our platforms, offering additional guidance and technical assistance.
CrowdStrike has released a public statement on Windows Sensor Update - crowdstrike.com addressing the matter, and it includes recommended steps for a workaround.
Posted Jul 20, 2024 - 10:41 UTC
This incident affected: ALIM (Session Service), Base Services (Bentley.com, Managed Services (Global Status)), ProjectWise Services (Deliverables Management, Portfolio Insights, Project Insights, ProjectWise 365, ProjectWise Design Integration, ProjectWise Drive, ProjectWise Web View), and iTwin Products (iTwin IoT).